Wednesday, February 10, 2010

Membuat Web Proxy Untuk Warnet menggunakan Mikrotik

Asumsinya ketika client1 mengakses website A maka proses yang terjadi adalah client1 meminta/request ke web server yang mempunyai website A tersebut. Ketika client2 atau yang lain mengakses website yang sama (website A) maka proses client tersebut akan mengulang kembali proses meminta/request ke web server tersebut. Seandainya ada banyak client lain yang mengakses website yang sama (website A) maka proses yang sama akan dilakukan lagi. nah inilah yang membuat akses terasa lambat.

Disinilah peran sebuah Proxy sangat dibutuhkan untuk mempercepat akses website. Suatu halaman website yang pernah dikunjungi oleh client akan disimpan (cache) di server proxy. Ketika ada client yang meminta/request suatu website maka client tidak langsung request ke webserver. client akan mencari website yang direquest-nya ke proxy dulu, kalo ada maka proxy akan menjawab request tersebut dan memberikannya ke client, jika website yang dicari tidak ditemukan di simpanan/Cache proxy barulah proxy server request website tersebut ke webserver dituju.
Ada banyak macam proxy, untuk basis OS windows bisa menggunakan winroute,winproxy, dll. untuk basis OS linux bisa menggunakan Squid. Disini saia menngunakan basis linux mikrotik. selain handal digunakan sebagai router, mikrotik juga bisa digunakan sebagai web proxy server. settingannya dibawah ini yang saya gunakan.

Spek PC : 
P3 800 Mhz, Mem 256, HD 30 Gb, 2 buah LAN Card (1 LAN onboard, 1 LAN tambahan)
OS : Mikrotik OS 2.29.XX
ISP : Telkom Speedy (Profesional) 1 line
Modem merk Sanex standard bawaan speedy
Client : 10 komputer

Konfigurasi Mikrotik :

#1. Setting Interface LAN card
/interface
set ether1 name=modem
set ether2 name=lan
keterangan:
ether1 diganti nama (interface) menjadi modem (koneksi dari dan ke modem)
ether2 diganti nama (interface) menjadi lan (koneksi dari dan ke jaringan LAN)
tujuannya biar mudah di ingat gak ada pengaruh ke akses-nya.

#2. Setting IP address
/ip address
add address=192.168.1.2/24 interface=modem
add address=192.168.10.1/24 interface=lan
keterangan :
ip address standart (umumnya) modem 192.168.1.1 jadi ip interface dari-ke modem antara 192.168.1.2-254 (suka-suka)

#3. Setting Gateway
/ip route
/add gateway=192.168.1.1

#4. Setting DNS
/ip dns
set primary-dns=202.134.1.10
set secondary-dns=203.130.196.155
set allow-remote-requests=yes
Keterangan :
DNS digunakan untuk menerjemahkan alamat IP ke domain (****.com, ****.net, dll) atau sebaliknya, ada beberapa DNS untuk speedy pilih yang latency-nya kecil dengan nge-ping agar akses ke dns-nya agak cepat dikit.

#5. Setting NAT
/ip firewall nat
add chain=srcnat action=masquerade out-interface=modem
keterangan :
Network Address Translation (NAT) fasilitas router untuk meneruskan paket dari ip asal dan atau ke ip tujuan dan merupakan standart internet yang mengizinkan komputer host dapat berkomunikasi dengan jaringan luar menggunakan ip address public.

#6. Setting web Proxy (transparent)
/ip web-proxy
set enabled=yes
set hostname=proxywarnetku
set transparent-proxy=yes
set cache-administrator=admin@warnetmu
Keterangan :
settingan web proxy yang lain menggunakan default bawaan mikrotik.
hostname=hostname dns atau ip address web proxy
cache-administrator=email admin yang bisa dihubungi ketika proxy error, yang akan ditampilkan pada browser client ketika proxy error.

#7. Setting redirect ke proxy
/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-port=3128
keterangan :
Redirect digunakan untuk membelokkan/memaksa koneksi port 80 (www/web) dari client ke port 3128 default-nya web proxy mikrotik, jadi semua request client yang menggunakan port 80 (www/web) akan di belokkan ke web proxy mikrotik.

#8. Memonitor web proxy
/ip web-proxy
monitor interval=1
keterangan :
memonitor penggunaan web proxy mikrotik dengan interval waktu 1 detik
Hasilnya : memuaskan dan bikin puas…puas…!
Sengaja tidak setting DHCP karena ip client (windows) disetting manual hubungannya dengan billing warnet. Untuk jaringan yang besar dan client banyak sebaiknya menggunakan Squid di linux.

3 comments:

Anonymous said...

trims atas ilmunya mas,
kalau boleh saya mau konsultasi juga mas, kebetulan saya buka game online dengan 10 client dan 1 billing. provider speedy, windows xp sp2, athlon x260, memory 2gb, vga 1gb, khusus billing memori 3 gb. saya mau mengurangi 1 client untuk dijadikan proxy. bagaimana cara membuat proxy dan spek yang harus digunakan.
trims atas jawabannya mas.

Fahrizal D'Scooter-Boy said...

Kalo untuk game online tidak bisa memakai proxy,, karena game online sendiri secara traffic dia hanya ke IIX jadi buat apa di proxy. kadang proxy malah menjadikan hambatan untuk game online.

Hendra Wahyu said...

Maaf sebelumnya, bukannya bisa yah game untuk proxy? seperti teknisi teknisi jaringan dia membuat proxy untuk game, sehingga setiap ada game update, dia tidak perlu update kembali. CMIIW

GodexsZone © 2009. Design by :Godexs_zone Templates